Quick Comments FAQ

初出日: 2008年10月22日 | 最終更新日: 2009年3月25日
投稿者: をかもと | パーマリンク

Quick Comments に関する「よくある質問と答え」です。

Q1 : プラグインを有効にしても動作していないようなのですが…

A1 : お使いのテーマの以下のところをご確認ください。

ヘッダー(header.php)
<head> ~ </head> の間に <?php wp_head(); ?> と言う記述があること。
無ければ、</head> の直前に <?php wp_head(); ?> と言う行を追加してください。

フッター (footer.php)
</body> の前に <?php wp_footer(); ?> と言う記述があること。
無ければ、</body> の直前に <?php wp_footer(); ?> と言う行を追加してください。

単一記事の投稿(single.php)
<?php get_header(); ?> と言う記述があること。
無いようなら、最初の行に <?php get_header(); ?> を追加してください。(このテンプレートタグを書き込んだ所に ヘッダー (header.php) の内容が読み込まれます。)
ただし、<!DOCTYPE ~> <html> <head> で開始している場合は、</head> の直前に <?php wp_head(); ?> と言う行を追加してください。

<?php get_footer(); ?> と言う記述があること。
無いようなら、最後の行に <?php get_footer(); ?> を追加してください。(このテンプレートタグを書き込んだ所に フッター (footer.php) の内容が読み込まれます。)
ただし、</body> </html> で終了している場合は、</body> の直前に <?php wp_footer(); ?> と言う行を追加してください。

Q2 : コメント送信後、メッセージボックスが表示されます。
メッセージボックスに表示される内容は HTML 文のようなのですが…

A2 : 設定の「コメントリストの CSS パス」が正確に記載されていない可能性があります。
もう一度確認して、再設定してください。

Q3 : IE6でだけ、正常に動作しないのですが…

A3 : IE6のバグに起因するものかも知れません。
IE6 では <!DOCTYPE ~> 宣言の前に何か文字があると「後方互換モード」で画面をレンダリングします。
これは、<?xml version="1.0" encoding="UTF-8"?> と言う XML 宣言も例外ではありません。
なので、ヘッダー(header.php) の1行目で XML 宣言をしている場合、以下のように修正して IE6 の場合は XML 宣言を出力しないように修正する必要があります。

<?php
$ua = $_SERVER['HTTP_USER_AGENT'];
if(!(ereg("Windows",$ua)>0 && ereg("MSIE 6.",$ua)>0)){
echo '<?xml version="1.0" encoding="'.get_bloginfo('charset').'" ?>';
}
?>

Q4 : Prototype.js または mootools.js などのライブラリと併用しようとすると JavaScript エラーが発生します。

A4 : Quick Comments が使用している jQuery.js が、Prototype.js または mootools.js とコンフリクト(競合)を起こして JavaScript エラーが発生しているのかもしれません。
<head> 部で JavaScript をロードする際に
Prototype.js → jQuery.js → mootools.js
の順でロードするように修正する必要があります。
また、jQuery.js ロード直後に、以下の3行を追加する必要があります。

<script type="text/javascript">//<![CDATA[
jQuery.noConflict();
//]]></script>

Q5 : コメントを連続して投稿することができません。

A5 : WP-SpamFree プラグインを導入している場合、コメントの連続投稿ができなくなるようです。
申し訳ありませんが、今のところ回避策はありません。

Q6 : IE8 からコメントできないようなのですが…

A6 : IE7 エミュレートモードで無いと正常に動作しないことがあるようです。
以下のコードを header.php の </head> より上に挿入してください。

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

なお、将来のバージョンでは、この問題を修正する予定です。